Back to overview
Degraded

Unicast is down

May 23, 2026 at 11:53am UTC
Affected services
Unicast

Resolved
May 23, 2026 at 10:40pm UTC

Unicast recovered.

Updated
May 23, 2026 at 10:29pm UTC

Unicast is degraded.

Updated
May 23, 2026 at 9:52pm UTC

Unicast recovered.

Updated
May 23, 2026 at 9:50pm UTC

Unicast is degraded.

Updated
May 23, 2026 at 8:08pm UTC

Unicast recovered.

Updated
May 23, 2026 at 7:59pm UTC

Unicast is degraded.

Updated
May 23, 2026 at 5:20pm UTC

Unicast recovered.

Updated
May 23, 2026 at 5:07pm UTC

Unicast is degraded.

Updated
May 23, 2026 at 2:04pm UTC

Unicast recovered.

Updated
May 23, 2026 at 2:02pm UTC

Unicast is degraded.

Updated
May 23, 2026 at 1:43pm UTC

Unicast recovered.

Updated
May 23, 2026 at 1:38pm UTC

Unicast is degraded.

Updated
May 23, 2026 at 12:58pm UTC

Unicast recovered.

Updated
May 23, 2026 at 12:47pm UTC

Unicast is degraded.

Updated
May 23, 2026 at 11:55am UTC

Unicast recovered.

Created
May 23, 2026 at 11:53am UTC

Unicast is degraded.